MacBook(Lion)にRabbitを入れたい

インストールメモ。

  1. rvm に ruby1.9.3 をinstall
    $ rvm install 1.9.3
    ERROR: rvm requires autoconf to install the selected ruby interpreter however autoconf was not found in the PATH.
    

    こんなエラー見たことない。ぬぬぬ。

  2. rvm のupdate
    $ rvm version
    rvm 1.6.5 by Wayne E. Seguin (wayneeseguin@gmail.com) [https://rvm.beginrescueend.com/]
    

    古すぎます。ごめんなさい。

    $ rvm update
    ERROR: rvm update has been removed. See 'rvm get' and rvm 'rubygems' CLI API instead
    

    updateはもう使われていないので新しいコマンドを使いましょう。

    $ rvm get latest
    

    再読み込み

    $ rvm reload
    RVM reloaded!
    

    確認。

    $ rvm version
    rvm 1.9.2 by Wayne E. Seguin (wayneeseguin@gmail.com) [https://rvm.beginrescueend.com/]
    

    OK。

  3. rvm に ruby1.9.3 をinstall(再)
    $ rvm install 1.9.3
    $ rvm use 1.9.3
    

    さくっと入りました。バージョン確認は怠らないこと。

  4. rabbitをinstall
    $ gem install rabbit
    uilding native extensions.  This could take a while...
    ERROR:  Error installing rabbit:
    	ERROR: Failed to build gem native extension.
    
            /Users/sally/.rvm/rubies/ruby-1.9.3-p0/bin/ruby extconf.rb
    checking for GCC... yes
    checking for rb_define_alloc_func() in ruby.h... yes
    checking for rb_block_proc() in ruby.h... yes
    checking for new allocation framework... yes
    checking for attribute assignment... no
    checking for Win32 OS... no
    checking for gobject-2.0... no
    *** extconf.rb failed ***
    Could not create Makefile due to some reason, probably lack of
    necessary libraries and/or headers.  Check the mkmf.log file for more
    details.  You may need configuration options.
    

    なんか出た。gobject-2.0がないらしい。調べてみると、gobject-2.0はglibに入っているようである。

  5. glibをinstall
    $ brew install glib
    ==> Installing glib dependency: gettext
    /usr/local/Cellar/gettext/0.18.1.1: 365 files, 13M, built in 6.3 minutes
    ==> Installing glib dependency: libiconv
    /usr/local/Cellar/libiconv/1.14: 24 files, 1.4M, built in 75 seconds
    ==> Installing glib
    ==> Downloading ftp://ftp.gnome.org/pub/gnome/sources/glib/2.28/glib-2.28.8.tar.bz2
    curl: (28) FTP response timeout
    

    ftpのダウンロード先が遅くて、もうちょっとのところでタイムアウトになってしまう。

  6. glibを落としてくる
    こちらの記事と同様、https://github.com/mxcl/homebrew/issues/3476の現象がおきていたので、curlにオプションをつけてglib-2.28.8.tar.bz2を落としてきた。

    $ curl -O --disable-epsv ftp://ftp.gnome.org/pub/gnome/sources/glib/2.28/glib-2.28.8.tar.bz2
    

    時間はかかったけどなんとかファイルを手に入れた(6000Kで10分)。
    ~/Library/Caches/Homebrew/に置く。

    $ brew install glib
    Error: The linking step did not complete successfully
    The formula built, but is not symlinked into /usr/local
    You can try again using `brew link glib'
    

    再びエラーが出た。symlinkedに失敗しているということでメッセージに従いコマンドをたたく。

    $ brew link glib
    Error: Could not create symlink /usr/local/include/glib-2.0.
    Check that you have permissions on /usr/local/include
    

    把握。

    $ sudo brew link glib
    

    OK。

  7. atkも足りない
    $ gem install rabbit
    …
    checking for atk... no
    

    次はatkか。。

    $ brew install atk
    => Installing atk dependency: pkg-config
    /usr/local/Cellar/pkg-config/0.25: 8 files, 232K, built in 50 seconds
    ==> Installing atk
    /usr/local/Cellar/atk/2.2.0: 181 files, 2.5M, built in 63 seconds
    

    linkは同じようにあとからつけた。

  8. もう、こわくない。はず。
    $ gem install rabbit
    …
    checking for pango... no
    

    足りない物をいれていけばいい。

    $ brew install pango
    ==> Installing pango dependency: pixman
    /usr/local/Cellar/pixman/0.22.2: 9 files, 1.0M, built in 56 seconds
    ==> Installing pango dependency: cairo
    ==> Exit Status: 2
    http://github.com/mxcl/homebrew/blob/master/Library/Formula/cairo.rb#L20
    Error: Failed executing: make install 
    These existing issues may help you:
        https://github.com/mxcl/homebrew/issues/7658
        https://github.com/mxcl/homebrew/issues/8144
        https://github.com/mxcl/homebrew/issues/8491
    

時間いっぱい。続きは明日。(所要時間3時間)
上記のgithubを読んでみよう。


3 comments:

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です